Jump to content
Forums forums
PRIMETIMER
SilverStormm

Bad Ad?: Please Report Here

Recommended Posts


This is really a bug, but there doesn't seem to be any place to report bugs.

For at least a week, when I access the site from a PC running Windows 10 and Edge, I will have giant ads blocking the site.  Often these are telling me that my virus software is expired (it isn't), today it was a big Spotify ad.  Sometimes they come up immediately after accessing the site, sometimes after I have been on for a few minutes.

Doesn't happen with iPads or iPhone access.

Share this post


Link to post

Every time I click a forum link to try to read a thread, my browser gets redirected to some spam website (typically telling me I need to renew Norton, or some deal for Verizon customers, etc.)  The websites are total spam and flood my browser "back button".  This is the only website its happening on, and only when I try to read a forum thread.  Not sure where the issue lies?

Edited by jcin617

Share this post


Link to post

Not sure if this counts as a bad ad or not.

For the last 10 days or so I have been getting redirected to a Norton screen telling me my coverage has expired.   I have verified that this is a scam.  It comes intermittently, sometimes when I enter a thread for the first time, other times when I go from one page to another in the same thread.  Once I am on this screen, I cannot back out of it to get back to Primetimer, I have to close that window and reenter the website.  

Primetimer is the only website where I have encountered this problem. 

Share this post


Link to post

I keep getting scam messages that pretend to be from security companies like Norton and McAfee that take over my Primetimer screen, saying my license has expired and I need to resign up immediately.  This only happens to me when I'm on Primetimer.  I have to shut the tab down and bring it up again.  Is this happening to anyone else?

  • Like 1

Share this post


Link to post

Desktop, Windows 10, Edge

I've gotten them for McAfee, Symantic, Norton, Spotify

Don't have URLs because I close them as soon as they come up.

It only happens on PrimeTimer.

  • Useful 1

Share this post


Link to post
9 minutes ago, meep.meep said:

Don't have URLs because I close them as soon as they come up.

Can you let me have the URL of (or link to) a Primetimer page where you've experienced this, which topic etc, thanks.

Share this post


Link to post

It doesn't seem to be linked to a topic.  Usually they show up as soon as I open the site.

If I close the bad ad, then restart PT, it doesn't reoccur.

Share this post


Link to post
5 hours ago, meep.meep said:

Desktop, Windows 10, Edge

I've gotten them for McAfee, Symantic, Norton, Spotify

Don't have URLs because I close them as soon as they come up.

It only happens on PrimeTimer.

Same for me, but I have a Surface, not a Desktop.

Share this post


Link to post
8 hours ago, meep.meep said:

Desktop, Windows 10, Edge

Same for me.  I won't have an URL for the reasons others have mentioned, but I will note the forum and page next time it happens and post it here. 

Share this post


Link to post

Desktop, Windows 10, Edge.  The location on this site doesn’t seem to matter it’s almost always when I click to go into any thread.   I’ll try to grab a screenshot later.

ETA:  Actually today it has seemed OK, so far.

Edited by jcin617
  • Useful 1

Share this post


Link to post

Has the above been resolved for all or is anyone still experiencing this issue?

Share this post


Link to post
On 5/21/2020 at 10:04 AM, SilverStormm said:

Has the above been resolved for all or is anyone still experiencing this issue?

I have not experienced the anti-virus pop-up for some time now, at least a month. 

I am still, however, having the issue where I cannot "X out" the bottom ad.  It happens randomly when I visit the site, and it's not related to whether I sign out or not (I seldom do). Per your request, I've been tracking whether there are any particular ad or ads where this happens but it does not seem to be. 

Laptop, Windows 10, Edge.

Share this post


Link to post

What is the deal with the constant ads featuring rats in the forums? Have reported them to no avail. I realize ads keep this website up and running but the constant rodent ads are disgusting.

  • Like 2

Share this post


Link to post
On 5/30/2020 at 8:34 PM, rcc said:

What is the deal with the constant ads featuring rats in the forums? Have reported them to no avail. I realize ads keep this website up and running but the constant rodent ads are disgusting.

To enable us to track it down, please provide a URL where you have experienced one of these ads. Thanks.

On 5/22/2020 at 5:53 PM, Quilt Fairy said:

I have not experienced the anti-virus pop-up for some time now, at least a month. 

I am still, however, having the issue where I cannot "X out" the bottom ad.  It happens randomly when I visit the site, and it's not related to whether I sign out or not (I seldom do). Per your request, I've been tracking whether there are any particular ad or ads where this happens but it does not seem to be. 

Laptop, Windows 10, Edge.

Apologies for the delayed response, I missed this somehow.

I'll report the ad failing to remove issue.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Customize font-size